Audio Streaming IPTV encoder


I have been streaming audio and video via the HDMI input without issue, today I am testing using the audio input and the audio drops out every few seconds. Am I doing something wrong?

Wifi connection and the audio input is a stereo cable from iphone playing music.


My friend:

In order to save time and get better understanding of the problems, please provide the
information as below, this will help us to get a solution faster.

a. The full page Screenshots of status
b. The full page Screenshots of media
c. The full page Screenshots of access

Have a good day.


hello My friend:

Sometimes the different Sound sampling rate is different .when it change, The encoder not work good ,you need to reboot it and try a same sound to confirm it.

And we will try local and Find the cause of the problem.

Thank you .have a good day.


my friend:

today we check it at this setting ,it work good .

When you change the Resample(hz) adn the Audio Encode,you need to reboot the VLC or the decoder, if not reboot VLC ,it will look like audio freezing.
Just reboot the VLC ,it will be work good.

And we advice the Resample(hz):disable

if you have any question ,plesse feel free to contact me.




I really cant push 1024 bit rate, I would like to leave it around 600, what should I set the frame rate to?


For example, set the frame rate to min (3-4fps) or/and resolution: 480*270.


my friends:

we found a bug of the encoder.
when the audio file or video files audio resample change, the audio will frezzing every some seconds.

our enginner are working to got a firmeware to correct it.

if it go out .we.will send to you.

Thank you and have a good day.


I confirm this fact, after changes in the signal parameters - Reboot is needed.


Please add support for 48000 Hz (48k) in the encoded streams and in Media > Audio Input section “Resample” option.
I notice that if my video source has HDMI signal with 48kHz audio, the signal drops every couple of seconds, with “Resample” setting set to “Disable”. If I enable resample to 44.1k, audio does not drop anymore, but audio quality gets bad (it aquires some metallic distortions due to bad quality of resampling).

It would be best to avoid resample completely, and simply allow 48k in the encoder. 48kHz is IPTV and DVB standard for digital audio among the video signals.


Hmm strange. I noticed that I was not able to disable resample anymore, even after reboot.
Had to: change to line in > reboot > disable resampling > reboot > change back to hdmi audio > reboot
After this, I have 48kHz audio in the stream and no dropouts anymore, and perfect sound without metallic artifacts.


My friend:

Could you try to reboot your VLC to check the encoder every setting of encoder ?
Some times it will course the freezing,when you change the setting but not reboot decoder.
Do you use set box or VLC to decode the video?

Have a good day.


Naturally I restart VLC and the set box playback every time I change anything in the encoder.


ok let me talk to the fimeware engenner.


My friend:

Could you help me to check the new firmeware has the problem or correct it ?