FBE200 + ffmpeg = "Past duration too large warning"


#1

Greetings,

In my application, I use the FMUser FBE200 (H.264 + LAN) model using it to encode HDMI from a Panasonic GH4 camera to stream directly to a PC and loop that video back into Video4Linux2.

Over many years of tweaking, I have determined that the best way to acquire video from the FBE200 under Linux and utilize it in streaming application such as OBS is to decode and loop the video back through v4l2loopback.

For those interested and to help reproduce the warning message - here is the pipeline I use:

This loads the v4l2loopback kernel module and creates 3 devices with exclusive capture support

sudo modprobe v4l2loopback exclusive_caps=1 video_nr=10,11,12 card_label=“Device 10”,“Device 11”,“Device 12”

This calls ffmpeg using a single thread to obtain the rtsp stream from the FBE200 and directly write that video to the video loopback device

ffmpeg -threads 1 -rtsp_transport tcp -y -i rtsp://fmuser:554/main -c:a copy -pix_fmt yuyv422 -f v4l2 /dev/video10

This results in a very stable video with nearly NO latency! However, after about 2-10 minutes of streaming, I begin to receive a large number of “Past duration too large” warnings coming back from ffmpeg.

Past duration 0.749901 too large
Last message repeated 2 times
frame=91181 fps= 30 q=-0.0 size=N/A time=00:50:42.40 bitrate=N/A dup=17 drop=0 sPast duration 0.749901 too large
Last message repeated 8 times
Past duration 0.749565 too large
Past duration 0.749901 too large
Last message repeated 1 times
Past duration 0.749565 too large
Past duration 0.749901 too large
Past duration 0.749565 too large
Last message repeated 1 times
frame=91197 fps= 30 q=-0.0 size=N/A time=00:50:42.93 bitrate=N/A dup=17 drop=0 sPast duration 0.749565 too large
Last message repeated 1 times
Past duration 0.749901 too large
Past duration 0.749565 too large
Last message repeated 10 times
frame=91211 fps= 30 q=-0.0 size=N/A time=00:50:43.40 bitrate=N/A dup=17 drop=0 sPast duration 0.749565 too large
Last message repeated 1 times
Past duration 0.749229 too large
Past duration 0.749565 too large

While this warning appears, I don’t notice any trouble with the stream or any loss in frames, however the warning still bothers me and I’d like to see if there is any way to make it go away. I’ve tried making many adjustments but I’ve never been able to clear up this warning, like firmware upgrades for both the FBE200 and the GH4 camera, to swapping out the computer, trying different versions of ffmpeg, upgrading the Linux OS etc. Nothing seems to remove this warning!

Does anyone know what causes this warning and if there’s any setting or configuration that I can use to get rid of it?

Thanks!