IP streaming to IPTV server


#1

I am a commercial broadcaster. I have a small town and I need to broadcast a stream out of my CO with an FBE200 via an IP address. Once the IP and correct port hit the private network I am connected to an IPTV server that will collect the stream and rebroadcast it. I am replacing my old encoder with this one. The directions that came are vague for me as they are directed towards users trying to stream to a URL. Do you have more in-depth instructions for my scenario?


#2

My dear friend

  1. In your scenario, you just need to use FBE200 RTMP to push to the IPTV server.
    Like this application scenario

  2. Can you tell me what your IPTV server is?

Can you tell me more about it?

have a good day
Jimmy


#3

Yes I tried to in the main stream enter my IP with port in there using RTMP didn’t work, maybe a syntax error-how I am putting in there. Anyway I have a windows PC running a power point the display comes out HDMI. The receiving IPTV server is an APMax (Innovative)


#4

Ok I have tried everything cannot get it to stream I have my VLC hooked up and don’t see it either. Also the wireless will not work I have factory reset the unit and reloaded my settings and I never see the SSID or a stream. Does this unit need to go back to the factory?


#5

My dear friend

I am sorry for my late reply.
Because yesterday and the day before yesterday are weekends, I am on vacation.

  1. Unable to RTMP push may be because your settings are wrong,
    can you take a picture of all the FBE200 settings page to me?

  2. FBE200’s WIFI has no emission function, so without SSID, it can only be used to receive.

You still have to give me some pictures of settings, so that I can clearly know where your mistakes are.

have a good day
Jimmy


#6

I have the wrong settings I am sure. Please let me explain what I am trying to accomplish. If I am sending one stream out of this box, with an IP destination,using UDP. What fields actually need to be filled in on the Access tab? Main RTMP disabled and then fill in the mainstream info? Or do I put my stream IP in the “EXT STREAM” field? I am not using URL. I simply need to broadcast my IP with the video that is coming in out to a network that is looking for the IP I am broadcasting. Specifically an IPTV server that is receiving IP streams and rebroadcasting them to IPTV customers. I cannot give you a screen hot until I know what fields I am supposed to use.


#7

My dear friend

  1. If you want to use UDP to transmit video, you just need to set the following content.

  2. IPTV server reception settings, can you give me a screenshot?

  3. After setting up FBE200, you can use VLC to test whether FBE200 has stream output.

have a good day
Jimmy


#8

Ok where do I input the IP of my stream destination? My server is looking for a different IP and a different port number than that.


#9

My dear friend

Here you can set your UDP output address and port

have a good day
Jimmy


#10

Ok I get a picture now on my VLC player. It is not pretty. When I hook it into my network my APMax IPTV server does not see it. Here are some snips
image

image


#11

My dear friend

  1. What is your APMax settings? Can you take a picture for me to see?
  2. VLC viewing UDP protocol has a floral screen phenomenon, which may be caused by VLC’s playback cache. You can try to turn off VLC’s video acceleration function.
  3. I once met some servers that can only detect data from 10 Mbps. You can try this.

have a good day
Jimmy


#12

I do not want to change any settings in my VLC because right now with the settings in it I can hook up to the output of my current older encoder that is still working and see my channel working fine. I need to have the settings in the new one match that setup. Please see the attached wireshark captures. The first one (Blue) shows the old encoder outputting the correct stream. Notice it is MPEG, and the destination IP (where my IPTV server resides) is correct. The second one (yellow) Which is the new FBE200 has the source flopping from the correct source IP to a MAC address, the destination is incorrect, and the protocol is IGMPv3…


#13

My dear friend

How are you?

This is my setting. I didn’t have the same problem as you.



have a good day
Jimmy


#14

So that completely did not work here are my screen shot I put exactly what you said to put in there. I don’t see the proper Destination IP or port 8208 Plus where is my MPEG protocol in the wireshark capture? Is this box junk? What is wrong with it?


#15

image


#16


#17

OK so I loaded new software:
image

Then I changed the port setting:

image

Now my front screen says this:
image

My wireshark looks better but there is no 8208 port on my capture:

image