RTSP FFMPEG recording and VLC viewing are very instable - FBE200-H.264-LAN


#1

Hi Fmuser, all,

I just received a FBE200-H.264-LAN and I am facing an issue trying to record/view an RTSP stream.
The setup is fairly close to the default settings, and the encoder is directly connected (static IP) to the computer recording/viewing via ffmpeg/vlc.

The input is a computer (1080P-60FPS). The picture coming from the computer looks fine when viewed via the output of the HDMI splitter that also feeds the FBE200.

The settings used are the following:

The ffmpeg command I use is:
ffmpeg.exe -i rtsp://192.168.1.168:554/main -acodec copy -vcodec copy test.ts
or
ffmpeg.exe -rtsp_transport udp -i rtsp://192.168.1.168:554/main -acodec copy -vcodec copy test.ts

When viewing in VLC, I use the same URL (rtsp://192.168.1.168:554/main).

In both cases (ffmpeg and vlc), I get different results every time I try:

  • Sometimes it just fails, providing the error “rtsp://192.168.1.168:554/main: Server returned 404 Not Found” [ffmpeg provides this]
  • Sometimes it starts to record, but for 10 seconds, and just stops.
  • When viewing in VLC, I get a similar behavior: sometimes it just fails, and when it does not fail right away, it just stops playing after a couple of seconds.

As you can see on the screenshot the device version is: E264-20180408.

Can you provide some guidance that would help diagnose what is going on?
Do you advice using other parameters/options in the ffmpeg command I use?
Is the firmware I have stable (I don’t see it on the firmware topic of this forum, it seems newer than anything posted on the forum)

Thank you!


#2

Quick update on my efforts to work through this issue. I think I pinpointed something interesting.
The behavior described in my original post happens when no sound has been sent over the HDMI. Once sound has been sent (Audio count becoming greater than 0), the stream is stable using both FFMPEG and VLC.
Could this be a firmware bug?

Thank you!


#3

My friends

it looks you hdmi connect is not stable ,try to change the cable .

have a good day.
tomlee


#4

Hi tomlee,

Thank you for getting back to me.
I tried with three different HDMI cables and was able to reproduce the issue every time. One cable is a MediaBridge, one a BlueRigger and the other a generic HDMI cable.
Also, I tried with doing the same test with capture video coming out of another computer and also the same issue appeared. For information, if it helps, the HDMI signal on both computers I tested with came out from an Intel HD Graphics 2000 for one and Intel Graphics 4000 for the other one.

Thank you

Teddy