EnglishFrenchGermanItalianPortugueseRussianSpanish

YouTube data is being proxied via miaopai servers

Hi there

I have aTV fmuser FBE200 High Definition IPTV Encoder.

I have noticed that the outgoing data is streamed to YouTube via a Miaopai proxy server instead of reaching YouTube directly.

Is there a way to disable this in the settings?

I would prefer my data goes directly to YouTube.

Thank you.

My dear friend

FBE200 does not use the Miaopai proxy
Maybe your settings are wrong

You need to give me some screenshots of the fbe200 background management interface

have a good day
Jimmy

Hi Jimmy

Thank you for your reply.

Perhaps, but I had never actually even heard of Miaopai until today when I started looking at how the box was delivering data to YouTube.com

They are apparently a streaming video service rather similar to YouTube but for the Chinese market.

I am happy to do this, I will send them later when I get to the FBE200 :slight_smile:

Just to be clear.

The streaming is working fine, I streamed HD to YouTube for a few hours without any problem. Here is a screenshot from the Deep Packet Inspector on my security gateway which shows that although I have streamed 4.5GB of HD to YouTube, it went via Miaopai.

The DPI receives the hostname from the TCP packets when using RTMP.

I am grateful for your help.

kind regards, m

Dear Jimmy

Here are my settings as XML, the screenshots are also attached.

Settings as of 2020-02-12T15:53:00Z

Please note, I am only streaming via line in/HDMI (aac/h.264) -> YouTube over RTMP (main, URL mode) no other streaming settings are used, and there is no proxy setting that I could have changed.

<status>
<dev>
<dev_id>0011223344556677</dev_id>
<dev_ver>E265-20190624-HLS</dev_ver>
<vi_info>1080I50</vi_info>
<vi_icnt>0</vi_icnt>
<vi_ilost>0</vi_ilost>
<ai_disable>0</ai_disable>
<ai_sel>1</ai_sel>
<ai_sample>48000</ai_sample>
<ai_chs>2</ai_chs>
<ae_sample>48000</ae_sample>
<ae_type>AAC-LC</ae_type>
<ae_bitrate>64000</ae_bitrate>
<ae_count>473673728</ae_count>
<hls_url>:8080</hls_url>
</dev>
<main>
<rtsp>:554/main</rtsp>
<url>udp://@238.0.0.1:6010</url>
<rtmp>rtmp://a.rtmp.youtube.com/live2/v738-9u2z-w91k-7kff</rtmp>
<type>0</type>
<ctrl>1</ctrl>
<size>1280*720</size>
<fps>24</fps>
<bitrate>3500</bitrate>
</main>
<ext>
<rtsp>:554/ext</rtsp>
<url>:80/ext</url>
<rtmp>disabled</rtmp>
<type>0</type>
<ctrl>0</ctrl>
<size>720*480</size>
<fps>30</fps>
<bitrate>1024</bitrate>
</ext>
<t3rd>
<rtsp>:554/3rd</rtsp>
<url>:80/3rd</url>
<rtmp>disabled</rtmp>
<type>0</type>
<ctrl>0</ctrl>
<size>720*480</size>
<fps>30</fps>
<bitrate>1024</bitrate>
</t3rd>
<color>
<vi_luma>50</vi_luma>
<vi_contr>50</vi_contr>
<vi_hue>50</vi_hue>
<vi_satu>50</vi_satu>
</color>
</status>

<network>
<dhcp>1</dhcp>
<ip>192.168.100.168</ip>
<mask>255.255.255.0</mask>
<gateway>192.168.100.1</gateway>
<mac>00:D4:93:AB:CD:EF</mac>
<dns>192.168.100.1</dns>
<dns1>1.1.1.1</dns1>
<ip100_addr>0</ip100_addr>
<ip100_open>1</ip100_open>
<wifi_exist>0</wifi_exist>
<wifi_ip>192.168.1.150</wifi_ip>
<wifi_netmask>255.255.255.0</wifi_netmask>
<wifi_gateway>0.0.0.0</wifi_gateway>
<wifi_type>0</wifi_type>
<wifi_essid></wifi_essid>
<wifi_psk></wifi_psk>
</network>

<media>
<vi_width>1920</vi_width>
<vi_heigh>1080</vi_heigh>
<vi_fps>50</vi_fps>
<vi_inter>1</vi_inter>
<vi_mirr>0</vi_mirr>
<main_type>0</main_type>
<main_prof>2</main_prof>
<main_width>1280</main_width>
<main_heigh>720</main_heigh>
<main_fps>24</main_fps>
<main_gop>24</main_gop>
<main_bitrate>3500</main_bitrate>
<main_ctrl>1</main_ctrl>
<main_min_qp>18</main_min_qp>
<main_max_qp>51</main_max_qp>
<main_roll_speed>0</main_roll_speed>
<main_osd_open>0</main_osd_open>
<main_osd_x>100</main_osd_x>
<main_osd_y>100</main_osd_y>
<main_osd_size>72</main_osd_size>
<main_osd_color>1</main_osd_color>
<main_osd_alpha>128</main_osd_alpha>
<main_osd_txt></main_osd_txt>
<png_open>0</png_open>
<png_x>50</png_x>
<png_y>50</png_y>
<png_file>image.png</png_file>
<main_logo_open>0</main_logo_open>
<main_logo_x>20</main_logo_x>
<main_logo_y>20</main_logo_y>
<main_logo_kcolor>0</main_logo_kcolor>
<main_logo_alpha>128</main_logo_alpha>
<main_logo_file></main_logo_file>
<ext_type>0</ext_type>
<ext_prof>1</ext_prof>
<ext_width>720</ext_width>
<ext_heigh>480</ext_heigh>
<ext_fps>30</ext_fps>
<ext_gop>30</ext_gop>
<ext_bitrate>1024</ext_bitrate>
<ext_ctrl>0</ext_ctrl>
<ext_min_qp>10</ext_min_qp>
<ext_max_qp>51</ext_max_qp>
<ext_roll_speed>0</ext_roll_speed>
<ext_osd_open>0</ext_osd_open>
<ext_osd_x>100</ext_osd_x>
<ext_osd_y>100</ext_osd_y>
<ext_osd_size>72</ext_osd_size>
<ext_osd_color>1</ext_osd_color>
<ext_osd_alpha>128</ext_osd_alpha>
<ext_osd_txt></ext_osd_txt>
<ext_logo_open>0</ext_logo_open>
<ext_logo_x>20</ext_logo_x>
<ext_logo_y>20</ext_logo_y>
<ext_logo_kcolor>0</ext_logo_kcolor>
<ext_logo_alpha>128</ext_logo_alpha>
<ext_logo_file></ext_logo_file>
<t3rd_type>0</t3rd_type>
<t3rd_prof>1</t3rd_prof>
<t3rd_width>720</t3rd_width>
<t3rd_heigh>480</t3rd_heigh>
<t3rd_fps>30</t3rd_fps>
<t3rd_gop>30</t3rd_gop>
<t3rd_bitrate>1024</t3rd_bitrate>
<t3rd_ctrl>0</t3rd_ctrl>
<t3rd_min_qp>10</t3rd_min_qp>
<t3rd_max_qp>51</t3rd_max_qp>
<t3rd_roll_speed>0</t3rd_roll_speed>
<t3rd_osd_open>0</t3rd_osd_open>
<t3rd_osd_x>100</t3rd_osd_x>
<t3rd_osd_y>100</t3rd_osd_y>
<t3rd_osd_size>72</t3rd_osd_size>
<t3rd_osd_color>1</t3rd_osd_color>
<t3rd_osd_alpha>128</t3rd_osd_alpha>
<t3rd_osd_txt></t3rd_osd_txt>
<t3rd_logo_open>0</t3rd_logo_open>
<t3rd_logo_x>20</t3rd_logo_x>
<t3rd_logo_y>20</t3rd_logo_y>
<t3rd_logo_kcolor>0</t3rd_logo_kcolor>
<t3rd_logo_alpha>128</t3rd_logo_alpha>
<t3rd_logo_file></t3rd_logo_file>
<ai_sel>1</ai_sel>
<ai_vol>0</ai_vol>
<ae_sample>0</ae_sample>
<ae_leftright>0</ae_leftright>
<ae_type>1</ae_type>
<ae_bitrate>64000</ae_bitrate>
</media>

<access>
<mcast_ttl>127</mcast_ttl>
<net_mtu>1500</net_mtu>
<watch_dog>0</watch_dog>
<mux_mod>0</mux_mod>
<net_mod>2</net_mod>
<ts_188Cnt>0</ts_188Cnt>
<hls_sel>1</hls_sel>
<http_port>80</http_port>
<ts_packet>0</ts_packet>
<rtsp_port>554</rtsp_port>
<rtsp_tcp>0</rtsp_tcp>
<rtsp_g711>0</rtsp_g711>
<rtsp_auth>0</rtsp_auth>
<rtsp_auth_mode>0</rtsp_auth_mode>
<rtsp_auth_user>auth_user</rtsp_auth_user>
<rtsp_auth_pwd>auth_pwd</rtsp_auth_pwd>
<main_name></main_name>
<main_http>/main</main_http>
<main_http_open>0</main_http_open>
<main_rtsp>/main</main_rtsp>
<main_rtsp_open>1</main_rtsp_open>
<main_rtp_mode>0</main_rtp_mode>
<main_ucast_open>0</main_ucast_open>
<main_ucast_ip>192.168.1.160</main_ucast_ip>
<main_ucast_port>6000</main_ucast_port>
<main_mcast_open>1</main_mcast_open>
<main_mcast_ip>238.0.0.1</main_mcast_ip>
<main_mcast_port>6010</main_mcast_port>
<main_rtmp_devid></main_rtmp_devid>
<main_rtmp_pcode></main_rtmp_pcode>
<main_rtmp_open>1</main_rtmp_open>
<main_rtmp_mode>1</main_rtmp_mode>
<main_rtmp_url>rtmp://a.rtmp.youtube.com/live2/xxxx-xxxx-xxxx-xxxx</main_rtmp_url>
<main_rtmp_ip>192.168.1.170</main_rtmp_ip>
<main_rtmp_port>1935</main_rtmp_port>
<main_rtmp_app>live</main_rtmp_app>
<main_rtmp_stream>main</main_rtmp_stream>
<main_rtmp_user></main_rtmp_user>
<main_rtmp_pwd></main_rtmp_pwd>
<ext_name></ext_name>
<ext_http>/ext</ext_http>
<ext_http_open>1</ext_http_open>
<ext_rtsp>/ext</ext_rtsp>
<ext_rtsp_open>1</ext_rtsp_open>
<ext_rtp_mode>0</ext_rtp_mode>
<ext_ucast_open>0</ext_ucast_open>
<ext_ucast_ip>192.168.100.168</ext_ucast_ip>
<ext_ucast_port>6020</ext_ucast_port>
<ext_mcast_open>0</ext_mcast_open>
<ext_mcast_ip>238.0.0.2</ext_mcast_ip>
<ext_mcast_port>6030</ext_mcast_port>
<ext_rtmp_open>0</ext_rtmp_open>
<ext_rtmp_mode>1</ext_rtmp_mode>
<ext_rtmp_url>rtmp://</ext_rtmp_url>
<ext_rtmp_ip>192.168.1.170</ext_rtmp_ip>
<ext_rtmp_port>1935</ext_rtmp_port>
<ext_rtmp_app>live</ext_rtmp_app>
<ext_rtmp_stream>ext</ext_rtmp_stream>
<ext_rtmp_user></ext_rtmp_user>
<ext_rtmp_pwd></ext_rtmp_pwd>
<t3rd_name>3rd</t3rd_name>
<t3rd_http>/3rd</t3rd_http>
<t3rd_http_open>1</t3rd_http_open>
<t3rd_rtsp>/3rd</t3rd_rtsp>
<t3rd_rtsp_open>1</t3rd_rtsp_open>
<t3rd_rtp_mode>0</t3rd_rtp_mode>
<t3rd_ucast_open>0</t3rd_ucast_open>
<t3rd_ucast_ip>192.168.1.162</t3rd_ucast_ip>
<t3rd_ucast_port>6040</t3rd_ucast_port>
<t3rd_mcast_open>0</t3rd_mcast_open>
<t3rd_mcast_ip>238.0.0.3</t3rd_mcast_ip>
<t3rd_mcast_port>6050</t3rd_mcast_port>
<t3rd_rtmp_open>0</t3rd_rtmp_open>
<t3rd_rtmp_mode>1</t3rd_rtmp_mode>
<t3rd_rtmp_url>rtmp://</t3rd_rtmp_url>
<t3rd_rtmp_ip>192.168.1.170</t3rd_rtmp_ip>
<t3rd_rtmp_port>1935</t3rd_rtmp_port>
<t3rd_rtmp_app>live</t3rd_rtmp_app>
<t3rd_rtmp_stream>3rd</t3rd_rtmp_stream>
<t3rd_rtmp_user></t3rd_rtmp_user>
<t3rd_rtmp_pwd></t3rd_rtmp_pwd>
</access>

<system>
<dev_id>0011223344556677</dev_id>
<reboot_active>0</reboot_active>
<reboot_timeval>3</reboot_timeval>
<dev_ver>E265-20190624-HLS</dev_ver>
</system>

Thank you for your assistance with this.

(I have been in touch with the support team for the manufacturer of the DPI hardware, to ensure that they are also looking into why the stream is identified as Miaopai and not YouTube. I will report back here.)

Have a great day, m

screenshots

status:

network:

media:

access:

system:

My dear friend

There’s no problem with your fbe200 settings.
The setting of fbe200 data package is direct to RTMP server.
Maiopai is China’s video platform, which has no ability to forward packets to Youtube.

It may be caused by the wrong identification of your gateway.
You can try to use a laptop to monitor the fbe200’s packets.
You can use software like Wireshark for analysis.

have a good day
Jimmy